Пиши Дома Нужные Работы


Функции в EXCEL. Обработка массивов

Цель работы.Изучить:

· функции в Excel;

· обработка массивов.

 

Функции вводят в таблицу в составе формул либо отдельно. В Excel различают функции следующих видов: математические, логические, статистические, финансовые, функции даты и времени и др. Все функции имеют одинаковый формат записи и включают имя функции и находящийся в круглых скобках перечень аргументов, разделенных запятыми. При вводе функций удобно пользоваться Мастером функций, вызываемым кнопкой Вставка функций, расположенной на панели инструментов Формулы (рис. 2.2.1).

 

Рис. 2.2.1. Ввод функций

 

Если окно Мастера функций перекрывает нужные ячейки, перетащите его в другое место.

Математические функции выполняют различные математические операции, например, вычисление логарифмов, тригонометрических функций, преобразование радиан в градусы, возведение в степень и другие. Одной из распространенных математических функций является суммирование – СУММ.

Логические функции используются для построения логических выражений, результат которых зависит от истинности проверяемого условия. К логическим функциям Excel относится функция ЕСЛИ. Она определяет выполняемую логическую проверку. Формат:

ЕСЛИ (логическое выражение; значение 1; значение 2).

Функция возвращает значение 1, если заданное логическое выражение истинно, в противном случае возвращается значение 2.

На месте логического выражения можно использовать одну из логических функций и или или:

И (логическое выражение 1; логическое выражение 2,…);

ИЛИ(логическое выражение 1; логическое выражение 2,…).

В скобках может быть указано до пятидесяти логических выражений. Функция и принимает значение истина, если одновременно все логические выражения истинны. Функция ИЛИ принимает значение истина, если хотя бы одно из логических выражений истинно.

Статистические функции выполняют операции по вычислению параметров случайных величин или их распределений, представленных множеством чисел, например, среднего значения, стандартного отклонения и другие. Так, для того, чтобы найти среднее значение (среднее арифметическое), используют функцию СРЗНАЧ. Для подсчета количества чисел в списке используют функцию СЧЕТ. Подсчитать количество непустых ячеек в диапазоне можно с помощью функции СЧЕТЕСЛИ.

СЧЕТЕСЛИ – функция, подсчитывающая количество непустых ячеек, удовлетворяющих критерию внутри интервала.

СЧЕТЕСЛИ (диапазон; критерий).

Диапазон – диапазон, в котором нужно подсчитать ячейки.

Критерий – критерий в форме числа, выражения или текста, который определяет, какие ячейки надо подсчитывать. Например, критерий может быть выражен следующим образом: 32, "32", ">32", "яблоки".

СУММЕСЛИ (диапазон; критерий; диапазон суммирования)

Диапазон – диапазон вычисляемых ячеек.

Критерий – критерий в форме числа, выражения или текста, определяющего суммируемые ячейки. Например, критерий может быть выражен как 32, "32", ">32", "яблоки".

Диапазон суммирования – фактические ячейки для суммирования.

Ячейки в «диапазон суммирования» суммируются, только если соответствующие им ячейки в аргументе «диапазон» удовлетворяют критерию. Если «диапазон суммирования» опущен, то суммируются ячейки в аргументе «диапазон». Например: =СЧЕТЕСЛИ(B2:B5;">55").

Задания для выполнения

Задача1. Задать в столбце А (2 – 6 строки) произвольные числа. Найти их сумму в ячейке А7. Для этого, установив курсор в ячейку А7, следует вызвать Мастер формул. В открывшемся окне в списке категория выбрать Математические и нажать кнопку ОК. В текстовом поле Число следует указать диапазон ячеек, выделив в таблице соответствующие ячейки. Ввод формулы завершается нажатием клавиши ОК. Готовая формула должна иметь вид:

= СУММ(А2:А6).

Проверьте правильность ответа. Выполните этот же пример, пользуясь кнопкой «автосуммирование» на панели инструментов.

Задача2.Открыть новый лист. Задать в ячейках А1 и В1 произвольные числа. Если число А1 больше числа В1, в ячейке С1 напечатать их разность, иначе – сумму. Нет необходимости вычислять вручную, достаточно в ячейке С1 записать формулу:

=ЕСЛИ(А1>В1;А1-В1;А1+В1).

Изменив значение в ячейках А1и В1, посмотрите, что будет с содержимым ячейки С1:

Задача3. Определить, входит ли в заданный диапазон (5;10) число, содержащееся в ячейке А2. Ответ 1 (если число принадлежит диапазону) и 0 (если не принадлежит) должен быть получен в ячейке А4,в которую вводится формула:

=ЕСЛИ (И (А2>5;A2<10);1;0).

В ячейке А4получится значение 1, если число принадлежит диапазону, и значение 0, – если вне диапазона.

Задача4.

Создать таблицу, содержащую количество осадков в миллиметрах, построенную на основе наблюдений метеостанции г. Нижний Новгород (табл. 2.2.1).


 

Таблица 2.2.1

Количество осадков в миллиметрах

А В С D
Количество осадков (мм) табл. 1
 
Январь 37,2 34,5
Февраль 11,4 51,3 1,2
Март 16,5 20,5 3,8
Апрель 19,5 26,9 11,9
Май 11,7 45,5 66,3
Июнь 129,1 71,5
Июль 57,1 152,9 50,6
Август 43,8 96,6 145,2
Сентябрь 85,7 74,8 79,9
Октябрь 14,5 74,9
Ноябрь 12,5 56,6
Декабрь 21,2 22,3 9,4

 

Определить максимальное количество осадков, выпавшее за 3 года.

Определить суммарное количество осадков, выпавшее за 3 года.

Определить среднемесячное количество осадков по итогам трёхлетних наблюдений.

Определить максимальное количество осадков, выпавшее за один месяц, по итогам трёхлетних наблюдений.

Определить количество засушливых месяцев за все три года, в которые выпало меньше 10 мм осадков.

Определить дополнительные данные. Для этого необходимо использовать дополнительные ячейки.

7.1. Определить количество месяцев в году с количеством осадков в пределах (>20; <80) мм;

7.2. Определить количество месяцев в году с количеством осадков вне нормы (<10; >100) мм.

7.3. Определить максимальное количество осадков за 3 года (мм).

7.4. Определить суммарное количество осадков за 3 года (мм).

7.4. Определить среднее количество осадков за 3 года (мм).

Контрольные вопросы

1. Как выполняется задание функций в Excel?

2. Как производится обработка массивов?

 






ТОП 5 статей:
Экономическая сущность инвестиций - Экономическая сущность инвестиций – долгосрочные вложения экономических ресурсов сроком более 1 года для получения прибыли путем...
Тема: Федеральный закон от 26.07.2006 N 135-ФЗ - На основании изучения ФЗ № 135, дайте максимально короткое определение следующих понятий с указанием статей и пунктов закона...
Сущность, функции и виды управления в телекоммуникациях - Цели достигаются с помощью различных принципов, функций и методов социально-экономического менеджмента...
Схема построения базисных индексов - Индекс (лат. INDEX – указатель, показатель) - относительная величина, показывающая, во сколько раз уровень изучаемого явления...
Тема 11. Международное космическое право - Правовой режим космического пространства и небесных тел. Принципы деятельности государств по исследованию...



©2015- 2017 pdnr.ru Все права принадлежат авторам размещенных материалов.